Please update date in Drafts view....
  • Heya,

    So, I'm over my near heart attack of a few minutes ago.... and, no hard feelings. ;-)

    I had spent a few hours editing an existing Wordpress Page, saving (but not publishing) as I went.

    I made some changes I didn't like, and closed the window w/o saving the changes.

    Then I double-clicked the existing Page in the Main Window, and felt viscerally ill when I saw the old Page load into the edit window. And I mean OLD, like, "Wow, when is this version from?"

    Went to drafts (which is a pretty long list) and sorted by date, but nothing from today. When I scrolled around in drafts and the date on this page showed last July, when I first posted the page. Around then I think I screamed out loud and my vision got a little blurry and I felt sorta dizzy....

    But it turns out the draft was current.

    Yea!!

    But wow, what a scare. Could maybe the draft dates be updated on save? There may be a reason not to, but let's balance that against this sort of potential panic, please.

    Cheers,
    Michael J.
  • Hi Michael - yeah, I need to revisit the whole concept of "dates" as they pertain to drafts.

    The problem is there are many potentially meaningful dates, and different people want it to show something different. It may be that I have to add multiple columns and let people choose which to show.

    For example, it could be the date that it was first saved as a draft, the date it was first published, the date it was last edited or … last but not least, the date that it is scheduled to be published.

    Complicated, for sure. Sorry about the heart attack, but glad that you didn't end up losing your page!

    Daniel
  • I hear 'ya. I built a CMS that used dates to publish "only what changed" and we had something like four or five different mod_date fields.

    I think e.g. a pop-up in the header row to pick the field or sort works pretty well. Default to the common choice, power users figure out what they want. Possibly autosave pop-up state.

    Thanks for responding.

    MJ
  • Can I +1 this request?

    I realize dates can get messy, but it seems there are probably a lot of people like me who keep a lot of drafts for future consideration. It's such a bummer when I edit one and forget to change the date from the one a week ago (or six, or six months) and end up with a terribly back-dated post.
  • Thanks for the +1.
  • Erm, me too. And my friend who just hit the same problem. Maybe a 'knob' in the Preferences ?
  • Yes, please, +1 from me, too.

    My problem is somewhat different. I blog, but other publish the blogs I write. Those publishers complain that upload dates in WP will be used as publish dates.

    Would it be hard not to set the date, at all?

    -Marko.
  • Marko - by default MarsEdit does not set the date at all. It only includes a date in the post if you open the Post -> Set Date panel and choose something. So if there is a problem with the dates of your posts then it must be something to do with how WordPress is choosing a default date for the posts when you upload them.
  • This is a major issue for me as well. WordPress blog and whenever I submit a "draft" post, the date is set for the post to that date, even if it's not finished. When I actually do publish the post, it is back dated.

    The way it works in WordPress is that it does not back-date posts at all and uses a time of "now" for the date of the post whenever I publish.

    So while you say that this is a WordPress issue, I am not sure how that is true since that's not how it works in their interface.

    I would really appreciate if you can provide detailed instructions on how to fix it in WordPress.
  • Please understand that the logic that drives WordPress's web editing interface is in some ways dramatically different from the logic that drives their interface that MarsEdit connects to (the "API"). That is not a defense of the poor behavior, but just to say that there is a rational explanation for the behavior differering between the web interface and from MarsEdit, and it still being "WordPress's fault."

    The reason I can be so confident about this being "WordPress's issue" is that MarsEdit never specifies a date on a post when editing, unless you specifically set one.

    That said, as it's been some time now and apparently the bug is still in WordPress, it might be worth trying to come up with a workaround. Although MarsEdit avoids setting a specific date on posts specifically to ensure that the system's default behavior prevails, it might be a situation here where MarsEdit should proactively re-set the date to the current time when publishing a post that was previously published as a draft.

    The easiest way to fix this on a post-by-post basis right now would be to follow these steps:

    1. Open the published post in MarsEdit.
    2. Select Post -> Edit Date from the menu bar.
    3. Click the popup button and select "Now"
    4. Send to Blog.

    This will change the published date to the current time. Obviously if you want to set it to a different time you can fine-tune it as needed.

    Daniel
Start a New Discussion

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!