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1. Getting Started with Black Ink
This chapter introduces you to Black Ink
Welcome to Black Ink! In this chapter you will discover the main features of Black Ink 
and how to access crossword puzzles from the Internet.

The Puzzle Window
Black Ink displays each puzzle in its own window, allowing you to work on more than 
one crossword at a time. Each window has the standard title bar, including controls to 
close, minimize, and zoom. The filename of the puzzle is also displayed. The puzzle 
grid occupies the major portion of the window. You navigate within the grid as described 
in the Navigation section. The current clue is displayed above the puzzle grid. When 
open, the clue list drawer is attached to the puzzle window on the left, right or bottom 
edge.
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Opening Puzzles
The first thing you will want to do is get some puzzles to solve. Black Ink makes it a 
snap to download puzzles from the Internet. By default Black Ink displays a web puzzle 
browser dialog when it is first launched. Simply click on a puzzle source and youʼll be 
solving in moments!

At any time you may choose another web puzzle to solve by selecting “Open Web 
Puzzle” from the “File” menu. Both the launch-time browser and the Open menu contain 
all of the puzzle sources configured in Black Inkʼs Preferences dialog. If you find another 
source on the Internet, you can use Preferences to add it to the list. Even reorder the list 
to put your favorite puzzles at the top!

If you have existing puzzle files on your computer, simply choose the “Open” item from 
the “File” menu to choose the puzzle file.  Black Ink even provides an “Open as 
Unsolved” menu item in the “File” menu, useful for replaying old puzzles.

Navigation
Black Ink provides a number of ways to navigate within the puzzle. Many of the  
navigation mechanisms are directly affected by user preferences. (See the Preferences  
section of the Configuration chapter for more information.) When a puzzle is opened, 
the first word is selected, usually 1 across. The selected word is always identified by 
highlighting, with the highlight color determined by your system-wide preference. The 
focused square is identified by a darker shade of the highlight color. The grid itself is 
composed of white and black squares. White squares are active and can contain user 
typed characters. Black squares are inactive and cannot be modified.

Mouse Navigation
Black Ink provides for the use of the mouse for puzzle navigation. A single click 
anywhere within the puzzle grid on an active square will cause the focused square to 
change to that square. If the click occurs within the current focused square bounds then 
the orientation of the selected word may change. The orientation will not change if a 
valid selection is not possible for that square in that direction. This is frequently the case 
in cryptic crossword puzzles where only about 25% of the squares are part of both 
across and down words. When the focused square changes the selected word will also 
change, provided the new focused square is not a square within the currently selected 
word. When the selected word changes via this mechanism the orientation will remain 
the same. When the orientation changes the selected word always changes. You can 
also change the focused square and selected word by selecting a clue from either the 
across or down list in the clue list drawer. The default preferences specify that the 
focused square will jump to the first empty square in a word when you select a word 
from the clue list. See the Preferences section for this and other navigation preferences.

Keyboard Navigation
The main mechanism for interacting with the crossword puzzle grid is the keyboard. The 
default action when you type a letter is to fill the current focused square square with that 
letter and to move the focused square to the next empty square in the word. This 
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movement can be disabled or modified. (See the Preferences section of the 
Configuration chapter.) You can also move the focused square using the arrow keys. 
When navigating with arrow keys, the selected orientation and word can be changed by 
altering the direction of movement from horizontal to vertical or vice versa. For example, 
if the current selection is an across word and you press the down arrow key (assuming 
there is a valid square below the current focused square), the selection orientation will 
change to down instead of across. By default, the focused square does not change, but 
this behavior is also controlled by a preference. (See the Preferences section of the 
Configuration chapter.) Arrow key navigation moves the focused square through inactive 
squares but is constrained by the bounds of the puzzle grid. The tab key or return key 
can be used to move to the next word for the current orientation. The shift-tab key 
combination will move to the previous word for the current orientation.

Direct Word Navigation
Black Ink provides a quick navigation method using the keyboard that allows you to 
jump instantly to any word in the puzzle. By entering the number of the word and 
pressing the Return key the active square will change to the first square of the puzzle 
word specified. For example, to move from 1 across to 85 down you would simply enter 
85 and press Return. An overlay containing the digits entered is centered over the 
crossword grid as a visual aid. You can press Escape to cancel a partially entered 
number.

OneAcross.com Lookup
Black Ink makes it easy to search the OneAcross (http://www.oneacross.com/) online 
clue database. The OneAcross system connects clue text to crossword solutions. The 
service is free, with a suggested donation of $20 per year. The “Answer Pattern” 
specifies the number of letters in the word, and any letters that may be in the word 
positionally. For example, if there was a 4 letter word and the middle two letters were 
“NC”, the pattern would be “?NC?”. Black Ink will fill in the clue text, build the pattern 
based on the existing puzzle board contents, and display this in a window. The pattern 
and clue text can be changed before sending a query. When the query is sent, it will 
open your default browser and display the result page. Your browser is used to comply 
with the OneAcross usage guidelines. If you use this functionality regularly, please 
make a donation to OneAcross through their web site.
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Puzzle Timer
Black Ink provides a simple timer for keeping track of how long it takes you to solve a 
puzzle. The amount of time spent on the active puzzle since starting the timer will be 
displayed in the timer window. Switching to a different puzzle will cause the timer 
window to display the amount of time spent on that puzzle since starting the timer. If the 
timer has not been started the Start button will be enabled. If the timer has been started 
the Stop button will be enabled. The Timer window is shown below.

Menus
The menus in Black Ink are a combination of standard application menus and Black Ink-
specific menus. Items of interest are described in detailed below.

Black Ink menu
The Black Ink menu is used to access functionality that affects the application as a 
whole. Standard Mac menu items such as Services, Hide, and Quit will not be described 
here.

Menu Item Purpose

About Black Ink Displays credits and information about Black Ink.

Preferences… Displays the Preferences window for Black Ink. See the 
Preferences section of the Configuration chapter for 
detailed information.

File menu
The File menu is used for opening, saving, and printing puzzles.

Menu Item Purpose

Open Web 
Puzzle

A submenu appears with a list of your configured and 
enabled web puzzle sources. Select a source to 
download the latest puzzle and begin working on it.

Open File… Opens a crossword puzzle file. The file must be an 
Across Lite format file whose name ends with “.puz”.
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Menu Item Purpose

Open as 
Unsolved…

Opens a crossword puzzle file, clearing any previous 
answers before displaying it. Useful for resolving a pre-
viously completed puzzle.

Open Recent Opens a recently opened crossword puzzle file as 
selected from its sub menu. The list of recent items can 
be reset by selecting “Clear Menu.”

Close Closes the active puzzle window.

Save Saves the active puzzle window with its existing name.

Save As… Saves the active puzzle window, prompting for the loca-
tion and name of the resulting puzzle file.

Revert to Saved Reverts the active puzzle window to its last saved state, 
or its original state if there have been no saves since 
opening.

Page Setup… Provides the ability to modify standard page layout 
settings for the currently active crossword puzzle in 
preparation for printing. Page Setup also contains Black 
Ink-specific printing options. See the “Print Options” 
section in the Configuration chapter for more 
information.

Print… Prints the active puzzle window, allowing standard 
printer settings to be modified.

Edit menu
The Edit menu is used to perform a variety of text manipulation actions on the board of 
the active puzzle window.

Menu Item Purpose

Undo Changes the puzzle back to the state just prior to the last 
action. The name of this menu item will be appended 
with text to identify what the action was.

Redo Negates the effect of a previous Undo action.

Cut Word Cuts the active word, causing the squares to be emptied 
and the cut text to be added to the system pasteboard.
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Menu Item Purpose

Copy Word Copies the text of the active word into the system 
pasteboard.

Paste Word Pastes available text from the system pasteboard into 
the active word. If the available text is longer than the 
active word, it will be trimmed before insertion into the 
board. This action will replace any existing text in the 
active word.

Clear Word Clears the active word, causing the squares to be emp-
tied.

Enter Multiple 
Letters

For special puzzles that require multi-letter answers in 
some squares, this menu item facilitates the entry of 
such answers.

View menu
The View menu is used to adjust the appearance of the active puzzle window.

Menu Item Purpose

Show/Hide Clue 
Lists

Toggles the display of the drawer containing the puzzle 
clue lists for Across and Down. The menu name will be 
modified to reflect the effect of selecting it.

Show Puzzle 
Note…

Displays a window containing the text of the puzzle note. 
This menu item will be disabled if there is no note in the 
currently active crossword puzzle.

Show Puzzle 
Timer

Makes the puzzle timer window visible for the active 
puzzle window.
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Solution Menu
The Solution menu contains actions that are related to the puzzle solution, some of 
which are only available if the puzzle is unscrambled.

Menu Item Purpose

Check Current 
Letter

Compares the letter at the focused square to the correct 
answer, if known. The square will be marked as 
checked, according to the Square State appearance 
preferences.

Check Current 
Word

Performs “Check Current Letter” on each square in the 
focused word.

Check Entire 
Puzzle

Performs “Check Current Letter” on each square in the 
entire puzzle.

Reveal Current 
Letter

Reveals the correct answer for the focused square, and 
marks the character as having been revealed. The 
square will be marked as revealed, according to the 
Square State appearance preferences. Once a square 
has been revealed it cannot be changed.

Reveal Current 
Word

Performs “Reveal Current Letter” on each square in the 
focused word.

Reveal Incorrect 
Letters

Performs “Reveal Current Letter” on each square in the 
puzzle which currently has an incorrect answer.

Reveal Entire 
Puzzle

Performs “Reveal Current Letter” on each square in the 
entire puzzle.

OneAcross.com 
Lookup…

Displays the OneAcross Lookup prompt, pre-populated 
with the clue and answer text for the selected word. See 
the OneAcross Lookup section above for more 
information.

10



Window Menu
The Window menu is used to navigate among Black Inkʼs various windows.

Menu Item Purpose

Minimize Window Shrinks the puzzle window and places it in the Dock.

Zoom Toggles the window size between the largest reasonable 
size for the current screen, and the size you last set the 
window to.

Web Puzzle 
Chooser

Displays the menu of web puzzle sources available, in 
an easily clickable window.

Bring All to Front Brings all Black Ink windows to the foreground, in front of 
windows from other applications on your Mac.

Help Menu
The Help menu provides quick access to user documentation and support.

Menu Item Purpose

Black Ink User 
Guide

Displays this user guide.

Visit Support 
Forums

Opens the Black Ink discussion forum in your default 
web browser.

Send Support 
Request

Opens a new email message in your default email 
application, addressed to Red Sweater Support.
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Multi-Letter Input
Some crossword puzzles are created with themes that require multiple letters in a single 
square. Typing a letter in a square normally advances the input location to the next 
square in the word, so to enter multiple letters Black Ink features a separate input 
mechanism. To enter multiple letters, you may either control-click the square you wish to 
enter into, or else select “Enter Multiple Letters” from the Edit menu.  An enlarged input 
area will appear, allowing the entry of however many letters are needed:

To end editing press the return key. Note that it is possible to press return with an empty 
input area if entering multiple letters was not intended or to delete previously entered 
letters. For puzzles that contain multiple letter square answers the check and reveal 
functionality will take that information into account.

12



2. Configuration
This chapter details the configuration of Black Ink.
Black Ink has many configuration options, allowing a fine-tuned solving experience.

Preferences
Black Ink preferences allow you to customize certain display and behavioral 
characteristics of the application. Preferences are broken into four categories: 
Appearance, Startup, Solving, and Web Puzzles. Selecting Preferences from the Black 
Ink menu will cause the Preferences window to appear.
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Appearance Preferences
Appearance preferences are concerned with visual aspects of Black Ink.

The Square Status section of the Appearance pane controls the visual feedback Black 
Ink uses to convey information about the way a square was solved. As you solve, 
check, or reveal puzzle squares, information about the correctness of the square can be 
displayed by either a small symbol, or by a custom coloring of the answer text. The 
preview squares on the right side of the pane give immediate feedback about how the 
settings will look while solving. 

An “Incorrect” square is one whose value has been found to be different from the 
correct answer, after being checked with one of the “Check” menu items in the 
“Solution” menu. 

A “Checked” square is one whose value has been confirmed as the correct answer, 
after having been previously marked “Incorrect” by one of the “Check” menu items in the 
“Solution” menu. 

A “Revealed” square is one whose correct value has been supplied by Black Ink, using 
one of the “Reveal” menu items in the “Solution” menu.
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The Clue List section of the Appearance pane is used to change behavior of the clue 
lists. Check the “Opens automatically with window” checkbox if you want the clue list to 
automatically appear when a puzzle document is opened. 

Startup Preferences
Startup preferences deal with the behavior of Black Ink upon launching. Use these set-
tings to adjust the behavior according to your puzzle solving & downloading habits.

Enable the “Open Puzzles On Startup” option if you want puzzles windows that are left 
open in Black Ink when you quit to automatically reappear when you open Black Ink 
again.

If you disable automatic reopening of puzzles, or if none were open the last time you 
quit Black Ink, the application presents the Web Puzzle Chooser. If you would prefer to 
have Black Ink present a standard file chooser dialog, change the setting as desired.
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Solving Preferences
Solving preferences include options for the puzzle timer, automatic error correction, and 
for adjusting the mechanics of square focus while solving a puzzle.

Select the “Start timer when puzzle opens” option if you want Black Ink to show and 
start the puzzle timer immediately upon opening a puzzle document. See the Timer sec-
tion for more information.

The Square Focus section is used to control how the focused square changes when 
various actions occur. The “Change focus after entering a letter” checkbox enables or 
disables the selection of a movement mechanism. If this checkbox is unchecked, the 
focused square will not change when a letter is typed on the keyboard; you will move 
the focused square manually with the mouse or with arrow keys. If the checkbox is 
checked, one of two mechanisms will be used to determine how the focused square 
changes. The “To next blank in word” option causes the focused square to change to 
the next blank square in the word, or simply to the next square if there are no more 
blank squares. If “To next square in word” is selected, the focused square will always 
change to the next square in the word, regardless of its content. 
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“Move to blank after switching direction” causes the focused square to move to the first 
blank square in a word when the orientation is toggled via a mouse action. The mouse 
actions that qualify are control-click and right mouse click.

“Move to blank after changing words” causes the focused square to move to the first 
blank square in a word after you move to a new word using tab, shift-tab, return, or by 
mouse-clicking an item from the clue list.

“Pause on direction switch via arrow keys” defines the behavior when you change the 
orientation by pressing an arrow key. As outlined in the Keyboard Navigation section, 
the selection orientation and selected word can be changed by changing the direction of 
movement from horizontal to vertical or vice versa. When this preference is checked, 
the orientation will toggle, but the focused square will not change (unless it is necessary 
in order to facilitate an orientation switch). When it is unchecked, the orientation 
changes, and the cursor jumps to the next square in the word.

“Show incorrect letters as I type them” allows you to be alerted immediately when you 
make a mistake in solving a puzzle. This preference is not applicable to scrambled 
puzzles. 

Web Puzzles
Use the Web Puzzles pane to manage the list of puzzles that Black Ink knows how to 
download on your behalf. Puzzles that are checked as “Enabled” appear in both the 
Web Puzzle Chooser and in the Open Web Puzzle menu.
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The Web Puzzle downloads folder identifies the area on your disk where newly down-
loaded puzzles are saved. Black Ink organizes the contents of the folder by source 
name so it is easy to browse puzzle files in the Finder. 

18



Print Options
Black Ink provides support for a variety for printing-related options. These options are 
accessed in a slightly different manner depending on the version of Mac OS X you are 
using. On version 10.6 and later, these options are accessible from right within the Print 
panel, accessible by selecting “Print” from the “File” menu at the top of the screen. Click 
the blue button immediately to the right of the printer name popup, to expand the print 
panel and reveal Black Inkʼs custom options.

On Mac OS X 10.5 and earlier, the same options can be accessed within the “Page 
Setup” menu item in the “File” menu.

and earlier, access via the “Page Setup” item in the “File” menu. Select Black Ink from 
the Settings list in the sheet displayed on the puzzle window. You will be presented will 
the view shown below.

The print options are broken into two categories: Ink Saver and Content Options. Ink 
Saver allows you to specify a gray value between Black and Light Gray in which the 
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crossword grid will be printed. The closer the slider is positioned to Light Gray, the 
lighter the printed grid will be. Printing a lighter color should reduce the amount of ink 
used to print the grid on paper.

Content Options allows you to choose one of three pre-defined sets of printing content 
or to manually select what content will be printed. Selecting “Playable with current text” 
will print the puzzle grid, letters, numbers, and clues. Selecting “Playable with fresh grid” 
is similar but does not print letters. Selecting “Solution grid” only prints the puzzle grid 
and solution letters. Finally, selecting “Custom” allows manual selection of the content to 
be printed. Note that letters and solution are mutually exclusive. If the puzzle you are 
printing is scrambled, then the solution option will be unavailable.

Black Ink automatically determines if more than one page is required to print all the 
selected content. Generally speaking, puzzles with dimensions greater than 17x17 will 
require two pages if both “Puzzle Grid” and “Clues” are selected.
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3. Black Ink and Spotlight
This chapter explains Black Inkʼs integration with Spotlight.
Black Ink provides indexing for puzzle files so Spotlight can be used to find them.

Spotlight Integration
Mac OS X includes a system-wide search functionality named Spotlight. Spotlight frees 
you from remembering where files are stored by means of a powerful indexing engine. 
When installed Tiger provides support for many common file formats.

Third party applications like Black Ink that utilize special file formats like Across Lite 
must provide assistance to Spotlight in order to properly index files. Support for 
Spotlight is bundled with Black Ink and you need only run Black Ink once for indexing of 
crossword puzzles to occur. After the initial run any new puzzles will be indexed 
automatically as long as Black Ink is still installed on the computer.

Search Examples
Black Ink provides Spotlight with puzzle title, author, and copyright information. In 
addition all puzzles are identified as being in AcrossLite format. It is possible to perform 
searches using any or all of these items.

Finding All Puzzles
To locate all the crossword puzzles on your computer you can simply enter “AcrossLite” 
(without quotes) into the Spotlight search field.

Finding Puzzles By Author
To locate all the crossword puzzles by a particular author you can simply enter the 
authorʼs name into the Spotlight search field.

More Information
For more information about Spotlight visit Appleʼs website at 
http://www.apple.com/macosx/features/spotlight/ 
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Apple, the Apple logo, Mac, and Macintosh are trademarks of Apple Computer, Inc., 
registered in the U.S. and other countries. Across Lite is a trademark of Literate 
Software Systems. Black Ink is a trademark of Red Sweater Software. All other 
trademarks, service marks, and trade names belong to their respective owners.

Copyright © 2007-2011, Red Sweater Software.
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