Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Characters in titles

edited February 2007 in MarsEdit
I use my titles in javascripts, which doesn't work well with things like apostrophes. I tried to put the HTML code for these characters in the title but MarsEdit just changes them back to ASCII characters. I'd like to at least see this behavior changed and even have the option to have MarsEdit automatically change them to html version automatically.


  • You mean in JavaScript that you embed directly in the post content, I assume? I wonder if apostrophes are unique in this way - does MarsEdit erroneously switch back other entities that you use? Can you tell me exactly which entity you're using? Is it "'" or a numeric code?

  • For example, I use Haloscan for comments. In my Blosxom template I have something like this:


    The $Title is replaced with the title from the entry. Having a apostrophe in the title will totaly screw up the javascript function.

    If I try to use a &-pound-34; (forum software wont display it correctly, I got it from here) marsedit just removes it. I just tried using '. MarsEdit did keep that but displays it as it's true character. When I look at the txt file, it shows a '.
    That could be confusing if I go back and edit it. Thus if I knew MarsEdit was just taking care of them, I wouldn't need to worry about it.
  • Thanks for the the specific example - I will look into this more carefully and let you know what I find.

  • edited March 2007
    I can use &-pound-34; for a quotation, and marsedit doesn't remove it. Strange.

    Edit: &-pound-34; is for quotations and &-pound-39; is for apostrophes. Clearly I'm confused! MarsEdit does display the quotation mark. It doesn't remove the apostrophes, just doesn't show it all the time. It will not show the &-pound-39; in the listing of entries or the title field when you edit the entry. It does show it in the preview pane and does save it.

    &-pound-34; is shown everywhere, MarsEdit doesn't have a problem with that.
Sign In or Register to comment.