Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Multiple-characters bug in 1.1.5 (516) ?

edited January 2009 in Black Ink
I seem to remember an update recently that mentioned a fix for a bug handling puzzles that contain multiple-character squares, but I'm having the same trouble with today's NYT (premium) puzzle. Moving around in the puzzle causes characters to shift from one square to the next.

Let me know if I can provide any more useful information.


  • I had the same problem. In case this helps finding the solution: I had completed a small portion of the puzzle, with six or seven multiple letters, completed with the menu command and I then began to use the keyboard command for multiple letters when the puzzle letters began to shift and the puzzle became unsolvable. I then opened a fresh copy of the puzzle and carefully pulled down the menu option to use multiple letters (instead of the keyboard command). I complete the entire puzzle with no problem. Maybe there is a difference between keyboard and menu use?
  • I'm really sorry these bugs are still plaguing the app. I know it's a major drag to have to watch the puzzle get corrupted halfway through solving.

    Vicky, your suggestion that it might have something to do with using the keyboard shortcut is interesting. I will poke around with that and see if I see any problems there.

  • Folks, do you think you might have been using copy/paste on the multi-character entries? I have been testing and discovered that there are some bugs with this. E.g. if you select an existing multi entry and cmd-X to cut it. I will try to get this fixed but let me know if you think the bugs you are seeing are happening even if you don't do any copy/pasting.

  • I'm pretty sure I didn't do any copy-paste operations. Interesting about the menu method vs. keyboard shortcut.
  • I'm going to fix the issue I found with copy/paste. Aside from that I want to start taking this problem really seriously and iron out any remaining bugs. So I would ask if you run into it if you can try to find a reproduceable way for me to cause the the problem, it will help me to figure out the root of the issue and fix it sooner.

    I'll be posting links to beta-updates here as I make fixes, so we can try to winnow down the problems. I appreciate your patience. Hope to get this cleaned up soon.

  • I think I have a way to reproduce this in the latest release.

    - Take a crossword and fill in 1 Across with letters, but put multiple letters in the first box (I used both the keyboard shortcut and the menu item and both became screwy.)
    - now fill in 1 Down with letters (keeping the multiple letters the same in the first box)
    - move the cursor to the first box containing multiple letters
    - hit the space bar
    - screwy!
  • I encountered the space character flaw some time ago and thought Daniel had fixed it with (516). There is more to it than meets the eye, because when I try dlineberger's process, I don't have any problems.
  • Ah, yes! Well that begs the question, dlineberger. Can you cnofirm that you are using the latest version of Black Ink? (1.1.5).
  • Yes, I'm using 1.1.5, and I encountered the bug on the same puzzle that cmurtaugh did. However, it looks like it happens on any puz file for me.
  • I made a bunch of fixes, and hopefully this will iron out all the reported incidents so far:

    I appreciate any confirmation you all can give me about the issues being fixed in this beta build.

  • Okay, i tried the 1.1.6 (525) build, and it looks like it fixed the multiple letter issue for me. Thanks!
  • Cool, thanks for letting me know. If others on the thread can give the build a modest beating :) I will probably release a public update soon.

  • This beta fixes the problem for me. Thanks!
  • Thanks for the feedback! I have decided to publicly release Black Ink 1.1.6.

    You can "Check for Update" from the app, or download directly:

    Thanks for the help in isolating these bugs.

  • Glad to hear this is getting ironed out -- I've been shirking my testing duties in favor of the day job. So far as I could tell the puzzle wasn't "really" corrupted. Saving and reloading it seemed to display it correctly.
  • Your observation is correct, ephraim. The corruption was entirely in the "view" part of the app. So the visuals were corrupted while the underlying data was still correctly organized.
Sign In or Register to comment.