Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Bug (?) in Bookmarklet on Flock?

edited March 2007 in MarsEdit
The "Post with MarsEdit" bookmarklet doesn't work with Flock on my MacBook Pro (with Intel processor). I had chalked this up to something wrong with Flock, but the other night, I noticed that it does work with Flock on my Power Mac G5 (with PPC processor).

I don't see how the platform could possibly make a difference, but both machines are running 10.4.8, MarsEdit 1.1.3, Flock .7.10.2, with JavaScript support on. It's possible (even likely) that the bookmarklet installed on the G5 dates from before the bookmarklet on the laptop, since I've tried a number of times to install the bookmarklet on the portable without succcess.

What can I do to better diagnose this? Compare text on the bookmarklets? Is anyone else using Flock on an Intel-based Mac, and can you use the bookmarklet?


  • Hi fsteele - I just downloaded Flock 0.7.11 (default download from the home page) and couldn't reproduce the problem on my MacBook Pro.

    The problem is interesting because Flock is built on Mozilla, so I would expect the same problem to affect FireFox as well. Have you tried this? Might be worth a test.

    One thing that popped out at me is that when you first click the bookmark bar in Flock (or FireFox) it will ask you whether you want to allow the external application to launch. I said yes, but I wonder if I had said "Cancel" and clicked the "Don't ask again" button, if I'd see this kind of quiet failure that you're seeing.

    One thing to try would be to just type "marsedit:" into the URL field and hit return. Does that work? It should launch MarsEdit.

    If that works, then there must be something subtle going on in the specific Bookmarklet script. Let us know and I'll follow up further!

  • Daniel -- that must be what happened, although I would normally shy away from the "Don't ask again" button. Typing marsedit: into the URL field does nothing but slumber peacefully.

    Can you see a way to get a second crack at that dialog box other than wiping every trace of Flock?
  • fsteele: I just set my Flock test up to basically misbehave as you described, by choosing the "don't ask again" option and canceling. Then I discovered the setting in the "secret" Mozilla preferences registry:

    1. Type "about:config" into the URL field and press return.
    2. Type "mars" into the filter text field to find the affected preference value.
    3. Double-click the value to toggle it to "true" or control-click it and choose "Reset" from the popup.

    I think now you will be reprompted the next time you try to access MarsEdit. This time - press OK :)
  • Thanks, that did it.
Sign In or Register to comment.