Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Posting Error

edited March 2007 in MarsEdit
I've just installed WordPress 2.1.2. When I make a post from MarsEdit, I get the following error message:
Post to Weblog Error
Can't do post for StephenHargrove because the server reported an error. The server did not respond.
However, the post gets made. When I check the blog, it's there. Following is the RPC Console. Any assistance would be appreciated.

RPC message sent: 2007-03-13 15:30:58 -0500
Method name: metaWeblog.newPost
RPC reply received: 2007-03-13 15:31:01 -0500
Method name: metaWeblog.newPost
Status code: -1
Succeeded: NO

--Download Error--
Request text:
<?xml version=\"1.0\" encoding=\"utf-8\"?>
<value><string>This is a test post.</string></value>
<value><string>Test Post The Last</string></value>

Response text:


  • Interesting Stephen - the RPC console doesn't show anything very interesting, except of course that there's no response text :) I wonder if the server *is* responding but something is happening while MarsEdit tries to read through it.

    Can you peek at the System Console (/Applications/ and see if there are any messages from MarsEdit?


    Also, did this only start after updating to WP 2.1.2? Or is this your first try?

  •" said:
    2007-03-13 16:35:12.904 MarsEdit[489] HTTP download error -- Domain: POSIX Type: Connection reset by peer -- URL: code: 54
    This looks like configuration issue on my end but I have no idea where to start looking. Predictably, the behavior was the same prior to upgrading.
  • Hmm - I wonder if it could be something like a security router or firewall of some kind on your network or ISP?

    I am curious to know whether simply asking MarsEdit to "Refresh" your blog works. Can you get a list of your current blog posts into MarsEdit, or does that fail too?
  • My ISP doesn't block anything to my server. Offhand, I can't think of anything in the router that would block it.

    I can't get a list of my current blog posts, but it does show a correct listing of my categories.
  • That is very interesting, because the "get categories" is a POST call too. So if you look in the RPC Console you will probably find a Response Text: with the response following for the categories information.

    I'm sort of out of ideas for the moment but I'm going to play around with some things and see if anything brings up a lightbulb. Let me know if you run into any other interesting details.

  • This is definitely a networking issue. When I arrived home, I modified my /etc/hosts file to point to the internal, private IP address of my server and it works fine. So it's something between my office network, the interwebs, and my house. It'll take a bit of investigation to chase down.

    Daniel, I really appreciate your assistance on this, particularly when it became obvious that it wasn't a MarsEdit issue. The great majority of developers would've blown me off at that point. Your continued concern and curiosity about my issue was a breath of fresh air.

    I've just purchased MarsEdit, if nothing more than to support your awesome attitude.

    Thanks again!
  • Very interesting discovery. I am glad you let me know because it will save me some time trying to further pontificate on it :)

    And I really appreciate the purchase. Thanks very much!

  • I'll have to dig into my Apache configuration and see if something has been changed that might cause this. While I can post from MarsEdit, I can't from TextMate. And while I do have a list of categories, I'm still unable to pull a listing of recent posts. Since traffic is only on my internal network, it leads me to believe it's a server configuration issue. I'll see if I can increase the logging tomorrow.

  • edited March 2007
    Disabling the PHP Markdown plugin solved the problem. It didn't cause any issues in the 2.0 WordPress series, so there must be some compatibility issue with the 2.1 series. Updating the plugin to the latest version did not solve the problem. I tried both versions of the plugin and both result in the same error. Fortunately, it's not a plugin I use very often.

    Anyway, problem solved. Thanks again, Daniel.

    Edit: Syntax correction.
  • Interesting! Thanks for sharing the final resolution with us.
  • I had this same issue and after some trial and error, it was a matter of deactivating a plugin to get MarsEdit working properly again. Please not, though, that the plugin I had to deactivate has been enabled for a more than a year and only recently busted. It wasn't my host because I run my own VPS and built it out from scratch, so I'm still confused as to what exactly happened, but I have a solution. And that, my friends, is half the battle. ;)
  • BTW, my error message in console was:

    2007-06-27 20:36:20.749 MarsEdit[5749] HTTP download error -- Domain: POSIX Type: Connection reset by peer -- URL: code: 54
  • Ryan: I wonder if you have updated anything at all recently on your server. For instance, have you updated PHP ?
  • Daniel, I didn't update PHP since compiling it when I originally set up the server a few months ago. Funny thing is, I'm coming back to this thread because MarsEdit is complaining again that the posts to my WP blog fail (but they really don't). I didn't change anything, so I'm digging around to see what's up.

    I'm getting the same error I posted above. No response from the server. Hrm.

    I'm also experiencing the odd behavior of WP setting an entry to Draft when I go to edit it after it was published. Hrm.
  • Hi Ryan- are you in control of your server, or is it possible that your server administrator updated PHP without you knowing?
Sign In or Register to comment.