Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Font format options not working

edited June 2011 in MarsEdit
Hi there.. I am having a problem with my MarsEdit 3.3.. on Mac OSX 10.6.7..

When I am composing a new post, if I try to format text using the Fonts toolbar, most of the functions within it do not actually take effect. Specifically I am trying to use the strikethrough feature, but I noted that even the basic bold, italics, and underline to not work. These basic features DO work when I use the shortcut keys (⌘B etc).

I have rebooted several times, and updated to the latest available version of MarsEdit.

I have used these features in the past, and I don't recall any changes I have made between the last time I used them, and now.

Any ideas?



  • Hi Adam - I have it on my bug list that the Strikethrough and Underline items don't work as expected. It turns out this is a bit harder to fix than I thought it was going to be.

    However, things like Bold, and changing the font should work correctly. I have heard one other report that it's not working right, and I can't get to the bottom yet of why it wouldn't work. I wonder what font you are using in the editor. Did you change the standard editing font (in Preferences, Editing)?

  • Hi Daniel,

    Thanks for the quick response.

    You are right, the Bold and font-change works correctly, however along with underline and strikethrough, the colour option for the text (not the highlight, it's OK) and resizing don't work.

    The font I am using is for rich text editing is Lucida Grande 12, if I recall correctly, I may have set this when I first started using ME some time ago, but haven't modified these settings since.

    Happy to provide any other info you need or help in any other way to solve this..

    In the meantime, is there a shortcut key that I can use for strikethrough, or any other way I can work around this function, as well as colouring the text? (aside from editing the HTML, I am not familiar enough with the code).

    Thanks again.

  • Unfortunately I don't think there is a good workaround for Strikethrough except for going into HTML mode. For the text color, however, you should be able to use the stand "Color" panel also available from the Format menu.
  • Hi, Daniel!

    I have version 3.5.3 on 10.7.4 Mac OS X, and I faced similar problem with hot keys.

    In Rich Text editing mode keys like ⌘B, ⌘I and shortcuts for pasting links are working simultaneously — and I can't find any links between what I'm doing and their reaction (after saving as draft? after starting new paragraph? don't know, it just happens). Keys from formatting panel don't work at all, actually, I thought that it's just kind of help list :) I have A LOT of formatting in my texts and use it while writing AND editing post afterwards. What can it be? My editing font in Preferences is Lucida Grande 14 too.

    And I'm Russian, so my texts are cyrillic, if it's matter.
  • Hi Zabolotnaya - if the formatting keys are all working properly in a "new" post with no content yet, then I think this must have something to do with the specific content of your post you are editing. If you can send me the HTML for the post, I can test with the same content and see if I see the same issues.

    1. Open the post with all the formatting you are having problem changing.
    2. Select Post -> Edit HTML Text if you are not already in HTML mode.
    3. Copy/paste the content into a new email to

    If you can also tell me in the email a specific word/paragraph in the post where formatting is not working, that will help me.
  • Hi there, is this still a bug? Trying to do a strikethrough and no worky. I saw here in this thread that it was a bug about a year ago. Any workaround for me? I can do a little tiny bit of html if you can tell me what the code is for strikethrough and how to get to the html edit panel. That said, I'd much rather be able to do it through the rich text editor. Using MarsEdit Version 3.5.5 build 5222 on OSX 10.6.8. Any advice would be greatly appreciated, thanks!
  • Hi rachelsue20 - you are specifically trying to do strikethrough? I just confirmed that strikethrough is not working from the Fonts panel, so I'll have to look into that. In the mean time you can set up a custom formatting macro:

    1. Open a new post to access the "Format" menu in the menu bar.
    2. Select Format -> Customize (at the bottom of the menu)
    3. Click the + icon to add a new macro named e.g. "Strikethrough"
    4. For the opening HTML use:

    <span style="text-decoration: line-through;">

    5. For the closing HTML use:


    6. Assign a keyboard shortcut if you wish.
    7. Click OK.

    Now you should be able to select text in the editor and choose Format -> Strikethrough to get the desired formatting.

  • This macro works well (I assigned the keyboard shortcut ctl-cmd-y). I select the text, press the keyboard shortcut, and the strikethrough appears. But it doesn't toggle off.

    I did do a variation on your macro, replacing "line-through;" with "none;" and giving it a separate keyboard shortcut; it works. But it would be nice to able to toggle the original command, the way I can with the bold and underline commands.

  • I'm having this issue also. Trying to edit in Rich text and can't seem to get fonts or other format options from the font menu to work. Changes done in the basic drop down "Format" menu are working. This could be "user error", so my apologies in advance if I'm just not doing it right. Selecting the word on which I want to use strikethrough, going to font menu and selecting strikethrough. Nothing happens. Ideas?
  • Hi TMD - it looks like fixing this issue fell through the cracks. Sigh. It's still on my list but there are a ton of things and sometimes things get deprioritized in favor of other work. In the mean time I think the workaround described above to create a custom format menu item will be your best bet!
  • Thanks, the Macro worked for Strikethrough! How should I handle the rest of the font menu? Basically the entire "Style/Show Fonts" menu isn't working.
  • Let me know specific ones that you are missing or wish that they worked. Some of them e.g. the basics like Bold, Italic, etc. have counterparts in MarsEdit's own Format menu. Others I might be able to suggest a similar workaround with macros until I can get things working better.

    Basically the problem is that Fonts panel is mostly wired up to work correctly with a standard "text editor" on the Mac, and the web-based editor that MarsEdit uses doesn't always handle everything the way one might expect, so I have to add special support for it.
Sign In or Register to comment.