Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Posting to a Ning blog w/ MarsEdit

edited August 2011 in MarsEdit
I'm posting to Drupal6 and Blogspot blogs successfully using MarsEdit. However I also have accounts on a couple Ning sites and want to post to Ning based blogs w/ MarsEdit. Ning announced last summer that they now support the metaweblog API and specifically named MarsEdit as an app that would work.

Today I tried - edited a blog post using MarsEdit, clicked the Send To Blog button, and it gave me an error saying the server sent a response "Please enter content".

I tried looking here and a couple other places. FWIW the text is set to UTF-8. The Ning site in question is operated by a Norwegian but that might not mean anything. I am a moderator on that site but my access to administrator panels is limited.

FWIW MarsEdit does see my list of postings on that blog.

I eventually thought "screw it" and made a posting using the Ning site. Copied the HTML text out of the MarsEdit editor, pasted it into the Ning edit box, and it posted right away. THEN I clicked refresh in MarsEdit, it showed the new posting. I double clicked that posting and it came up correctly in the MarsEdit editor. Then I made a simple change to the text and clicked the Send To Blog button. It posted, but then over on the Ning the content of the posting was completely gone.

This indicates that MarsEdit is doing something wrong with the content


API endpoint:
MetaWeblog API
Blog ID: 1

Under editing I haven't checked the "encode with HTML entities" checkbox


  • edited August 2011
    Hi David - not tryibng to pass the buck but it's far more likely that Ning is doing something unexpected with the content, or expecting the content to be in a non-standard named field. Since MarsEdit works with dozens and dozens of other systems using MetaWeblog API, it's had years to get the basics of the API pretty well behaving perfectly.

    Your description of the error message "Please enter content" makes me think that it is indeed expecting the content to be in a field other than the standard MetaWeblog "description" field.

    However, the Ning documentation seems to suggest that they do use the "description" field:

    You can confirm that MarsEdit is included the "description" field in its message to your Ning blog, by viewing Window -> Network Log and searching for the text content of your post that you expect to be sent to the site.

  • edited August 2011
    Hm, I could get a post to go if it was simple text (except there was some problems) - but including pasted HTML for a youtube video is what gave the error message.

    ..that is..

    Made a test post with just a line of text in the body. It posted correctly, EXCEPT that the

    tags got messed up and it came out as "pContent in posting/p" -- namely the angle brackets were stripped off.

    I see in the network log that the description field got encoded this way:

    <value><string>&lt;p&gt;Hello, world!&lt;/p&gt;</string></value>

    Was posted as:

    David Herron test post #3
    pHello, world!/p

    As soon as I paste the youtube embed tags using Edit -> Paste HTML Source, that's when it triggers the "Please enter content" error.

    The youtube embed tags were similarly encoded in the description field.

    <value><string>&lt;p&gt;Hello, world!&lt;/p&gt;
    &lt;p&gt;&lt;iframe src="" width="420" height="345" frameborder="0"&gt;&lt;/iframe&gt;&lt;/p&gt;</string></value>

  • Hi David - it is normal for the tags to be encoded inside the description field. This is part of the XML specification and differentiates those tags form the markup of the XML document itself.

    It sounds like there is something wrong with the Ning server's processing of the XML document. I am not too familiar with Ning's infrastructure, do you know if they operate all their sites from a single "platform", or is it a situation where individual sites may be managed independently? I wonder if the whole Ning service is screwed up for MetaWeblog support, or if it's possible that just this one server is.

    You may want to do a sanity check by trying to use another blog editor such as Ecto to connect to the site. If it works, it would give us something to go on as far as what it may be doing differently from MarsEdit, and if it fails it would further support the theory that Ning's MetaWeblog support is not operating correctly.

  • Also, I was able to Google some results that look remarkably similar to the behavior you're seeing, but using a completely different blog editor from Windows (Windows Live Writer):

  • I too am interested in using MarsEdit to post to Ning. Any improvements in the meantime?
  • HI Adrian - I haven't had any progress in this regard myself. I would be interested to know if you have any luck adapting the Windows Live Writer advice linked above to trying to configure MarsEdit to work with it.

Sign In or Register to comment.