Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Shortcut keys not being shown properly with Canadian keyboard

edited April 2007 in FastScripts
Hey - new user here, I really like FastScripts Lite and wish I'd found this long ago!

One minor issue though. I happen to use the Canadian keyboard, which is identical to the US keyboard except it gives me the chance to have the Canadian flag in my menu bar. If I set up a keyboard shortcut while using the Canadian keyboard though, it doesn't display properly.

for instance, I go to the Preferences > Script Shortcuts panel and click in the shortcut column to add a shortcut of, let's say, command-option-Z to do something. All that the table view displays is "command option". No Z. The shortcut works properly, it just doesn't display in here.

Oddly enough if I switch to the US keyboard, it magically appears.

You can try this yourself by turning on the Canadian keyboard. System Prefs > International > Input Menu; select both the "US" and "Canadian" keyboards in the list, and also select "Show input menu in menu bar."

Then choose the Canadian flag in the menu bar. Try to set up a shortcut as described above. It only shows the command and option characters. Now choose the US flag in the menu bar, and select the shortcut in the table view. Poof, it magically displays command-option-Z.

Of course this is not a showstopper, everything works fine, it's just kind of odd.

Thanks for providing this very useful app!


  • PS. perhaps this is the same issue described in the "Problems of shortcut Keys displayed in menu" topic in the support forum.
  • Wow! Indeed, I was able to reproduce the problem very easily just by switching to Canadian as you suggest.

    Thanks a lot for sharing this - the problem was sort of vexing to me and I assumed I might need to get a Japanese keyboard or something to solve it. This makes a much easier test case so hopefully I can get to the bottom of it.

  • I've discovered the cause of this bug and it's fixed in FastScripts 2.3.2:
  • Daniel Jalkut said:
    I've discovered the cause of this bug and it's fixed in FastScripts 2.3.2
    No, I use version 2.3.3, and the problem is not fixed for e.g Swedish or Swedish Pro keyboard.
    (OS is 10.4.10 intel)
  • Thanks, heb. I guess the problem is trickier than I thought. Will look into this in more detail as soon as I get a chance.
  • I'm experiencing the same problem here on an Australian keyboard layout. Also using 2.3.3.
Sign In or Register to comment.