Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Adding folders to the Media Manager

edited February 2012 in MarsEdit
Maybe I'm a little dense, but I'm unable to add the download folder to the "folder" choices. I tried draging it from fined. I added it to FINDERS sidebar. Opened and closed MARSEDIT. I'm just clueless?


  • You definitely should be able to drag the Downloads folder in. What happens when you try dragging it in? It should appear at the bottom of the list below any other sources such as iPhoto, Pictures folder, etc.
  • The drag just disappears. No entry is made. I have IPHOTO and PICTURES. Nothing else. I'm applying the latest upgrade as the software informed was available. Maybe that'll make a difference?
  • I got it. I was dragging the placeholder for "downloads" in the left hand sidebar of finder. When it didn't work, I thought maybe. Used the actual director file "downloads" from the right hand window. That worked.
  • Accepted Answer
    Great to hear, thanks for explaining. I'm not sure if I could get that Finder-sidebar version of the Downloads folder to work or not.
  • I'm having a similar problem. The Media Manager doesn't recognize any other folder and when it's On My Mac, it just shows items in the My Pictures folder.

    Anyone know how I can change this behavior?
  • Hi Arturo - I know we ended up solving this through email, but I thought I'd post the solution here in case others run into it. The situation for Arturo was that the "Folders" section of the media manager had become sized very short, so there wasn't room for all the usual stuff that it shows, including the ability to drag in custom items. So the fix is to find the horizontal line below the popup menu in that area, and click and drag it down to expand the height of the section.
  • Hi Daniel -

    I'm having the same problem, but the fixes here don't seem to apply - I made this screen recording:

    I'm on Mac OS 10.7.3 & using MarsEdit 3.4.4.
  • Hi Deep - thank you for taking the trouble of recording the screencast. Something unusual is definitely going on in your case, because the folders list generally contains at least a couple basic standard pictures folders.

    I suspect some kind of permissions issue. Can you take a peek in your System Console log for any evidence that MarsEdit might be printing out warnings or errors related to this?

    Can you think of anything unusual about your home directory that might cause MarsEdit trouble? I.e. is it a network mounted volume, or encrypted, etc?

    Thanks for your help. I'd like to get to the bottom of this and fix it permanently in the app so that if it's a legitimate error condition, at least it gets reported to the user.

  • Accepted Answer
    Hi Daniel -

    I looked in Console & there was nothing.
    I also repaired disk permissions but it still happens.

    The home directory is VERY normal. The only things that I can think of are that
    1) I migrated this machine from an older machine using Migration Assistant a few weeks back
    2) As I was just using the Mac App Store to upgrade to the latest iPhoto - I got an error saying I had to do the the upgrade as a different user. To fix this I had to delete iPhoto entirely from the HD & then the install happened.

    I'd be happy to screen share with you if that would help....

  • Thanks for the offer to screenshare. I may take you up on that if we're not able to zero in on this soon. If it's not too much trouble, would you try making a new, test account on your Mac, just to determine whether this is an issue with MarsEdit and your Mac, or with your home folder/account specifically?

    I don't think the Mac App Store anecdote you reported is related, but since I ran into something similar I thought I would share the likely (annoying) cause: do you have Spotlight indexing disabled for the disk or location where your app is stored? It seems that if Spotlight is disabled Mac App Store throws a fit and claims you need to use another account.

  • Accepted Answer
    Sorry, I never think to check these forums (I'll go see if there is an email notification option)...

    The Mac App Store thing is fixed (I deleted all copies of iPhoto) - but no, I was indexing everything....

    So from the test account, everything works as expected! Another interesting note is that in the test account, the "Pictures" folder is already in the media folders list, while in my normal user's Mars Edit, there are no folders in the media folders list...

  • Accepted Answer
    Yeah, it sounds like something is causing MarsEdit to fail completely to load any of the sources from your home directory on your main account. Certainly, in spite of already having done the Repair Permissions step, I would take a look at ~/Pictures and see if anything pops out as different in the Get Info window (or ls -l) about the one in your main account vs the one in the test account. That would be a good next step in zeroing in on what's going on here.
Sign In or Register to comment.