Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

AppleScript cannot save new posts/documents

edited March 2012 in MarsEdit
When I create a post via AppleScript, I cannot save it and close it. Close works fine, but then it prompts to save. If I send a "save" handler, it doesn't save and the script hangs until it times out. I'm trying to make a large series of posts at once to migrate a blog from one platform to another, so having close and save work properly is key.

Here is an example script. It does the same thing for any save command or "close with saving".

tell application "MarsEdit"
set myBlog to blog "Foo"
make new document
tell document 1
set title to "Bar"
set body to "Baz"
set current blog to myBlog
end tell
end tell


  • Thanks - it looks like this is a bug in MarsEdit. I've reduced it to simply "tell document 1 to save" and it doesn't work as expected. I'm writing myself a bug.

    I strongly urge you to reconsider using MarsEdit as a migration tool. It's overwhelmingly likely that there are better tools for migrating from the systems you are switching between. Do your blogs not have export and/or import functionalities that will work for this?

  • I had put this project on hold for a while, but came back to it the other day to finish the migration. With the latest (beta) version, posting to the blog saves and closes the document without any specific save calls. The latter seems to still be broken in the latest beta.

    And, FYI, MarsEdit worked great as a migration tool. I was moving the blog portion of a self-hosted Drupal site over to Tumblr (I got sick of supporting Drupal). I used NetNewsWire to download every legacy post via RSS, and wrote a script to pull the posts from NNW and send them to MarsEdit. Worked like a charm!

    Better still, now I can use MarsEdit to update my new blog!!!
Sign In or Register to comment.