Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Tab does not create indentations

edited September 2012 in MarsEdit

I've run into a issue tonight that has really created a lot of frustrations for me. While working on a new post, I would try to press TAB to create a indentation. However, when I press the TAB key, it skips out of the text editor and moves over to the Add Category field. If I Shift-TAB it skips to the Post Title field. It seems that tabs for indentation do not always work when I want them to. If I close the editor and re-open it, indentation tabs work again, but then go away and tab begins shifting the focus around again.

Is there something I can change to disable tabbed focus changing?



  • I would also like to add that this typically only happens within a block quote. Tabs for indentation work fine outside of the block quote. However, block quotes allow me 1 tab indentation and then starts changing UI element focuses.

    I am using the designer view/non-html view to compose my post if that helps.
  • Hi - sorry about this confusing behavior. I can definitely see how tab would be expected to indent text in a "Rich Text" editor like MarsEdit offers. Currently MarsEdit defers to a more web-style formatting assumption that paragraphs will be styled with indentations, if needed, by the style/theme of the blog that is being published to. So it assumes that tabs are not important for indentation per se.

    I'm curious, if you just write multiple paragraphs and send them to your blog without indentation, does it appear as you would expect? I wonder if you could get away with trying to avoid the tab-indentations, and if that would still produce the formatting outcome you're looking for?

Sign In or Register to comment.