Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Log-in to Google Account loop

edited October 2012 in MarsEdit
When I try to upload my post to my blog, the "Please Log In" window just continually asks me to enter my password, even though MarsEdit indicates that my post IS uploading. Is this normal? My blog is through blogger, which takes an inordinate time to do anything (one of the reasons I am trying MarsEdit) but I worry that it's not uploading.
My apologies if this has been answered elsewhere, but I'm a newbie and couldn't find an answer in the first four pages of the MarsEdit forums.


  • Hi Helen - usually when "weird stuff" is happening with Google I think it has something to do with Google's own security anti-spam features causing mayhem. If you visit this URL and enter the code does it make any difference for subsequent connections from MarsEdit?
  • Hi Daniel, I have the same "Please log in" loop. Mine is a private Blogger account which I set up manually because the auto detect is not working. I can't log in.
  • Hi witzer - did you try visiting the same "captcha" link I suggested? If that doesn't help, please try grabbing the network log and sending it to me at

    1. Open MarsEdit
    2. Select Window -> Network Log from the menu bar.
    3. Clear the log if it's not already empty.
    4. Try to refresh the blog again from MarsEdit.
    5. Copy the network log contents.

  • Hi Daniel, I was changing the settings around. I seemed to manage to log in now. But I'm getting "Can’t get recent posts for xxxxx because the server reported an error".

    My settings is as follow:
    System name: blogger
    System API: Google Data Protocol 2.0
    API Endpoint URL: my private blog address
    Blog ID: my private blog ID

    I hit refresh and the network log is as follow:

    Network message sent: 2013-01-03 09:19:25 +0000
    Method name: Google ClientLogin Authentication
    Network message sent: 2013-01-03 09:19:28 +0000
    URL: [my blog address]?alt=atom-service
    Method name: GET
    Network reply received: 2013-01-03 09:19:34 +0000
    URL: [my blog address]?alt=atom-service
    Method name: GET
    Status code: 302
    Succeeded: NO
    --Fault Error--
    Fault code: 302
    Fault string:
    Response text:

  • Hi witzer - when you say the API Endoint URL is your "private blog address", do you mean the home page URL? It should be set instead to something like this:[your private blog ID]/posts/default

    The blog ID in the settings should be the same as in the API Endpoint URL as above.
  • Hi Daniel, thanks for the info. It's working now. I have been searching high and low for the information on API Endpoint URL but I couldn't find any. I put my own blog address just to test out whether it worked or not.

    May I know where can I get the information that says API Endpoint URL should be "[your private blog ID]/posts/default"? Is it officially from Google? I just need to know the source so that if others need the info I might be able to point out to them.
  • Sorry this isn't more obvious. It's not a thing that's documented per se by Google, it's just if you have a private blog MarsEdit can't figure out the details automatically. If you have lots of friends or clients who have private blogs it will probably be a good idea just to remember to tell them about this nuance.
  • Alrighty. Thanks for your support Daniel.
  • I'm getting a similar loop, but the error is different (and I tried the captcha link and had the correct API endpoint URL).

    This is the error: "Can't get recent posts for [private blog] because the server reported an error" Unsupported alt type: atom-service."

    Please help! It was working fine this morning but now everything is stuck.
  • Hi skyrocketjumper - looks like something dramatic has changed at Blogger. I'm seeing the same problem here. I'm going to get in touch with the Blogger developer team and see if I can figure out what's going on.
  • Hi again - it looks like they've fixed the problem now on Blogger's end. Can you confirm for me that you are able to connect again?
  • The way I was able to get this to work was move my account to 2 pass verfication. From there, I created a specific "app password" for my @google account.

    It is a bit of a long winded process, but that seems to be the forced change.

    Blogger requires that any external apps are authenticated - and the 2 pass verification is the way that is done.
  • Thanks for the info, rbuckland. I happened to switch to 2 factor authentication myself several months ago, so if there are new issues that only affect folks who haven't, it would make sense I'm not seeing them.
Sign In or Register to comment.