Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

403 error

edited June 2007 in MarsEdit
I'm trying to get started, and when I try to post a message to my blog (WordPress), or refresh, I get a 403 error. The RPC log says: You don't have permission to access /blog/xmlrpc.php
on this server.

I double checked the passwords and the permissions, and it all seems to be correct. Any ideas?


  • Hi there - it sounds like it could be a server configuration issue. Some hosting companies turn off access to the xmlrpc.php access point. You might have to ask them to explicitly turn access on for that URL. If you ask them they should understand what needs to be done.

    If it's not too private can you share some more details about your blog? If you don't mind giving me the URL I might be able to make some more guesses by looking at the web page, or confirm that it's a server configuration issue.
  • Oh - check out this thread:

    I thought this sounded familiar. Very similar sounding situation to yours, and it looks like if it's the same type of setup, you can turn access on yourself by adding a .htaccess file to the server.

  • edited June 2007
    Hi - thanks for the quick response. I tried the .htaccess file but still having the same problem. Also tried renaming the file and that gave me a 404 error (and I did remember to change the name on marsedit too :) )

    the blog is

    It's hosted at - I'll send their tech support a note too.
  • It's definitely something in the server configuration - a little test I like to do is simply accessing the xmlrpc.php file from a browser:

    Notice how even from the browser you get the "Forbidden" result?

    In summary, your tech support team should be asked to "enable POST requests to\".

    Let us know how it turns out - it might be yet another trick to add to the list in that other thread.
  • They're checking on it now - thanks!!
Sign In or Register to comment.