Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Server returning error messages but post has been edited

edited May 2013 in MarsEdit

I'm having problems posting to my blog. MarsEdit returns the message that it couldn't post because the server returned an error message: unknown error. But the revisions are in fact being posted (ditto new posts). I never had this problem with my MAMP installation - so i believe this must be something to do with how the server is set up. Has anyone else had this problem or have any idea what might be causing it?

My hosting provider hasn't been any help.



  • Accepted Answer
    Hi Andy - for some reason reports along these lines have been coming in more frequently lately, but I don't think anything has changed in MarsEdit to explain it. By any chance is your hosting provider DreamHost? It seems to be correlated with some of the folks seeing the problem.

    The root of the problem is that MarsEdit is getting a timeout from the server (it never responds to the request to publish the post), so it has to assume that it has failed. But the server has actually gotten far enough along to publish the post before failing to reply.

    I'm going to keep my eyes and ears open for clues about what's causing this to happen more often. I wonder if it's a specific hosting company, version of WordPress, or maybe a specific plugin that is causing the problem to occur.
  • edited May 2013
    Hi Daniel

    Thanks for the reply. Well I guess at least I'm not the only one ....

    My hosting provider is ( )

    I'm using WP3.5.1

    I wondered if W3totalCache might be the culprit, but turning off the page and database caching didn't help.
  • Hi Andy - do you mean it happens reliably enough that you can make a tweak e.g. turning off the page caching, and it will quickly happen again with just a few tests? Or is it a situation where you turn it off and then only after e.g. a day or so it pops up again?

    I am curious if you have a setup where it is happening so reliably that you could experiment with e.g. turning off the W3 Total Cache plugin entirely, and confirm it's totally unrelated to that.
  • edited May 2013
    Hi Daniel

    When I turned off page caching I kept on getting the problem with MarsEdit - no return to normal service at all.

    I must admit I feel a bit nervous about turning of W3 total cache as I spent half a day setting up the CDN and I don't want to lose the settings.

    I was wondering though about whether there might be a connection via xmlrpc - I have SlimJetpack installed and that seemed to be interacting with xmlrpc - but again I drew a blank: after disabling the plugin I was still getting error messages.

    Or could it be Organize-Series? (I haven't tried disabling that one)

    I could send you a list of the plugins I have installed and then maybe if you get other reports you could see if there were any commonalities.
  • Thanks - I have done some comparison along these lines already and unfortunately W3 Total Cache was the only common plugin in the case of two folks who are affected. That makes me think it either is W3 Total Cache, or is completely unrelated but based on something other than plugins (e.g. similarity of server configurations, network providers, etc.).

    I'm going to keep trying things. In the mean time I wish I had something better to suggest. I guess it goes without saying that you never see the issue when posting via the web interface of your blog? (If you ever do that anymore?).
  • edited May 2013
    "I have done some comparison along these lines already and unfortunately W3 Total Cache was the only common plugin in the case of two folks who are affected".

    I'll take a deep breath and check out disabling it temporarily.

    EDIT: deactivated W3TotalCache and still got the same error messages.

    No - no problems posting via the web interface.

    I'm managing to work around it, but hopefully there's a solution somewhere.
  • Thanks for taking the chance of deactivating W3 to get it out of the picture. Hopefully I'll be able to figure out what's at the root of all this soon.
  • Just to add, I'm having the same problems of getting the error message. Somehow, in the background, the post has successfully gone through. To add, I am not using any caching plugins and I'm on the Textdrive hosting service. Cheers.
  • Thanks isaakkowk - unfortunately I still don't have any great tips to share on this front. It seems like something people are running into more often, but I can't tell yet whether it's because of some widespread configuration issue on servers (this has happened before), or because of something going on with MarsEdit. I'm still looking, hopefully it won't be too much of a nuisance in the mean time. If in doubt about whether a post has actually posted, be sure to "Refresh" in MarsEdit to get up-to-date with the latest changes on the blog.
  • Thanks, Daniel. The error seems to happen via the Poster app on my iOS devices too. Seems more like a server issue than MarsEdit. But workarounds are always good to eliminate the error.
  • Thanks for the reassurance that it's happening elsewhere besides just MarsEdit. I will definitely keep my eyes and ears open to learn more about the problem, whether to work around it in MarsEdit or to help get the world to server administrators about how to avoid it on the server.
Sign In or Register to comment.