Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

MarsEdit 1.2 issues

edited June 2007 in MarsEdit
After installing the MarsEdit 1.2 update it asked me if I wanted to update the Keychain.

When I clicked Change All it began hitting the hard disk so hard it basically stalled the computer.

I had to Force Quit MarsEdit and other programs and restart.

Now I find that programs are asking for their login password, as if the Keychain file has been damaged in some way.

Also for some reason, Entourage refuses to complete its startup. I get the menu but the Inbox never appears.




  • Further followup...

    Looking in KeyChain utliity shows Keychain is empty. (hmm.)

    After restart, keychain entries reappeared and I am able to log into Entourage.

    I am guessing there is some bug in the Password storage part of MarsEdit that is getting confused about stored passwords.

    (Breathes sigh of relief that he hasn't crashed out his computer!)


    Mac Mini Intel Duo
    2 GB RAM
  • Hi dewelch - sorry to hear about the Keychain problems. I hear about these types of problems from time to time, and so far it's always fixed things to run "Keychain First Aid" from the Keychain Access application. Can you try that and let me know if it resolves the problem?

    I'm 99% sure that MarsEdit has nothing to do with this problem, but then again, it could be something subtle. I will ask around to see if any other developers have run into problems like this.

    Thanks for sharing and let us know if the problem is resolved.

  • Ran Keychain First Aid
    It reported problems, so I repaired

    Ran MarsEdit
    When I reached the Change All selection the same results occurred, -- endless, solid hard drive access.
    Very difficult to Force Quit, but was finally able
    System unstable
    Any other application attempting to access stored password stalls out.



    After a reboot the keychain came back, but I think it is definitely something with MarsEdit. I will try to give a little more detail to the process that occurred:

    Choose Check for Update from MarsEdit Menu
    Downloaded and installed up.
    Ran MarsEdit
    Main window came up and I was able to open and close existing posts
    Selected blog
    Clicked Refresh
    Message dialog "Do you wish to allow access to keychain, etc"
    Clicked Change All
    Solid read/write access to hard disk, according to my Menumeters hard drive indicators
    System slowed to a crawl
    Force Quit window shows several programs (not responding)
    After several minutes Password dialog show for particular blog
    Enter password, click OK,
    Again, solid read/write access on hard drive which continued until I Force Quit.
    Machine totally unstable
    Keychain utility shows no keychain items
    Keychain utility errors when attempting to create new Keychain
    Kernal Panic
    Force restart
    System seems to be ok, but I have not tried to run MarsEdit again at this point.

    The read/write to the hard drive was what had me most concerned. I wasn't sure I was going to have a workable system when I rebooted after that.
  • Thanks for the info - I can definitely understand being scared to try running it again. The thing is, nothing has changed in MarsEdit that has anything to do with the keychain, so I'm at a loss as to how it could be a MarsEdit thing specifically.

    Without running MarsEdit, and after running Keychain First Aid again to repair everything, can you locate MarsEdit's keychain item for your blog in Keychain Access, and just delete it? Maybe it's somehow corrupted in a way that is not being repaired by Keychain Access.

    This is the first I've heard of any problem like this that doesn't get fixed by Keychain First Aid - if anybody else reading has ideas to share I'd be most grateful.

  • One other thing is have you considered letting the keychain complete its process, even if it sounds like it's slamming the hard drive? I can imagine it might freak you out a bit, but it's possible it's just doing a lot of work for some reason.

    One other thing to try would be to run Disk First Aid on the disk to make sure there are no errors on the disk.
  • Hmm - somebody else is reporting a very similar problem now, so something does seem fishy. This is really confusing since I don't *think* I changed anything having to do with the keychain or the way it is used. But what it looks like is happening is that the keychain is being accessed from two separate threads in MarsEdit, and that is causing a deadlock or something.

    I've obviously got some tinkering to do to try to get this figured out. I wish I could reproduce the problem here, though. If anybody else has thoughts on the issue, I'd love to hear them.

  • dewelch: the other person affected by this issue had good luck with deleting the keychain items for MarsEdit. Instructions are here:

    I'm still not sure what's going on but this might at least get you back on course until I can figure out the root of the problem.

  • No keychain issue for me, but ME suddenly thinks it's not registered. Also the Sparkly autoupdate didn't seem to work. (app didn't quit and relaunch). Problem persists with manual download. Most of the menus are greyed out as well. Just doesn't seem right... :-(

  • ztephen: can you tell me whether there is anything interesting from MarsEdit in the System Console?

    The symptoms you're describing sound like a corrupted "Application Support" folder. You might try to make a backup of that folder and then delete it. Just to see if that's the problem.

    If that works you might try to drag back in the things you want to salvage from the old folder, like the "Local Drafts" folder.

    I'm not suggesting this is something you should have to do, but given the unfortunate state things are in it might be the best path to a resolution.

    I wonder if the botched auto-update somehow caused the failure. Do you recall if there was any crash or if it just failed to quit and relaunch?

  • dewelch: if by any chance you still have the bug (haven't worked around it yet) can you do me a favor and try to reproduce it one more time before deleting the keychain items?

    I was in touch with the keychain engineers at Apple, and they suggested two things:

    1. Make sure there isn't a security dialog hiding somewhere on the screen unnoticed, that needs to be clicked.

    2. Take a sample of the "securityd" process to report a bug.

    To do the securityd sample, you would follow these steps:

    1. Open Activity Monitor (/Applications/Utilities/Activity Monitor)
    2. Find securityd in the list (type it in the filter for "All Processes")
    3. Double click it to open the window for it.
    4. Click the "Sample" button in the lower-left corner of that window.

    If you (or anybody else!) can catch securityd in the act of "hanging" MarsEdit, then we might be able to make some progress!

  • I think it asked me to authenticate (I run as a standard user most of the time) and then appeared to do... nothing. I'm not sure about that, as I wasn't paying attention.

    I'll check out the console and try App Support folder wrangling when I get back from work.

    Appreciate the quick response...
  • Right then.

    Checked console and system logs, nothing there.

    Deleting the App Support folder made no difference, but removing the prefs did.

    Then I could reregister and now have a brand new shiny working MarsEdit.

    Probably have to file this one under "Mysteries of the Universe". Though I guess it could be a sign that my filesystem is going wrong... therefore nothing to do with ME at all. Ho hum.
  • ztephen: I'm definitely not a fan of the "mystery of the universe" type bugs :) But I am glad to hear that things are back in order now.
  • Well, all I meant was it probably was nothing to do with MarsEdit, and possibly a lot to do with the chattering coming from my hard disc...

    I have, however, noticed that my blog's dashboard shows "New Post" and "Updated" entries on MarsEdit sourced posts. Harmless I suppose, but I'm curious why it's doing that.
  • Hm - interseting catch re: the "Updated" thing. I think it's because of a peculiarity in the way the remote editing interface works with setting categories. I believe MarsEdit has to first submit the post and then edit it to get the categories to show up correctly. I should look at this more carefully again to see if it's still necessary.
Sign In or Register to comment.