Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Upload problem with 1.2.1

edited August 2007 in MarsEdit
MarsEdit was uploading images and posts fine until I updated to 1.2.1. Now I get an endlessly spinning beach ball when I try to upload an image or a post. Also, if I upload with a separate FTP app and type the IMG code manually, I get a placeholder frame in the preview but no image.

I'm using MarsEdit 1.2.1, Mac OS X 10.4.10, a MacBook Pro with 2 GB RAM, and WordPress.

I'm afraid that I don't have Internet access at my new home, so I won't be able to check answers quickly. Any help appreciated even if I don't respond with thanks immediately.



  • Hi Craig - the first thing I'd suggest is let's verify that the problem is really new with 1.2.1, and didn't start happening coincidentally. Can you redownload 1.2, and give that a try:

    If the problem is indeed new to 1.2.1, I think the "upload post" scenario will be easier to debug. Can you open the RPC Console (from the Window menu), and keep it visible on the screen while you try to make the post. Do you see anything happen in the RPC Console?

    Finally, if you're getting a "beach ball", it would be very helpful if you can take a "sample" of MarsEdit while it's spinning:

    1. Open /Applications/Utilities/Activity Monitor
    2. Locate and double-click MarsEdit in the list of processes.
    3. Click the "Sample" button in the lower left corner of the window.

    Thanks! We'll get to the bottom of this.
  • Thanks for your patience.

    First, I should say that the problem seems to be solved.

    I was not able to test things systematically because

    a. I didn't have regular Internet access for quite a while

    b. after I reverted to version 1.2, my MacBook Pro had to go into the shop for unrelated repairs

    c. I used an older version of MarsEdit on an older computer, and it worked fine

    d. when I got the MacBook Pro back from the shop, uploading and posting worked fine in 1.2 and fine also in 1.2.1 after I upgraded again.

    So I can't shed light on what went wrong, but at least it's all right now.

  • Great- thanks for tying up the loose ends here :)
  • Sorry to keep coming back with similar problems, but today I don't seem to be able to post again. In the RPC Console I get the following:

    Response text:

    403 Forbidden


    You don't have permission to access /blog/xmlrpc.php
    on this server.

    Apache Server at [Web site URL] Port 80

    I fiddled with permissions on the site but keep getting the same result.

  • Hi Craig - this type of error is unfortunately out of the hands of MarsEdit. You'll have to talk with your hosting provider to see why they're not allowing access to your xmlrpc.php script. Sometimes this is a security decision on the part of hosts. It's a real pain :)
  • I'll check at the hosting end. I kind of figured posting here didn't make much sense, but it was late, and I was tired. Thanks.

  • It's always fine to post here - sometimes it is something that has an easy workaround, but in this case the server is just rejecting the access outright so it's hard to say what could be causing it. The hosts will probably have a quick and easy answer for you.
  • Well, you were right. Here's the message that I got from my hosting service.

    "This was because of mod security installed on the server, this has been disabled for your domain, please try it again and let us know if you continue to have problems."

    I tried again, and the post uploaded without any problem. Thanks for pointing me in the right direction.

  • Great! Now wouldn't it be nice if they said all that in the error message :)
Sign In or Register to comment.