Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Using a symlink rather than an alias?

edited January 2008 in FastScripts

With Adobe CS3, they've changed the security model for running user scripts (not AppleScript as such, but extended JavaScript, with the extension "jsx"). If you try to run a script that lives outside of ~/Documents/Adobe Scripts, the app asks if you're sure you want to run it. It's a minor irritation if you're only running a script occasionally, but if you've hooked it up to a keyboard shortcut for frequent use it becomes very inconvenient, very quickly. A workaround is to put your application's scripts into the official Adobe Scripts folder, and make an alias back to ~/Library/Scripts/Applications/ so that FastScripts can see it.

This works great. Only problem is: I use rsync to backup to an offline server nightly, and it doesn't recognise aliases. It works fine with a symlinked folder, but then the menu items don't show up in FastScripts. So my question there any way to get FastScripts to follow symlinks? Or any clever workaround that I've overlooked?

Thanks for your help!


  • Hi Ian - unfortunately links and aliases have been a weak spot in FastScripts, historically. I *finally* got aliases worked out and they're handled pretty well now, but I haven't tackled links yet. At this point now that I've worked out a lot of the aliases stuff, links might be relatively easy to add support for, but I haven't tested it yet.

    So - the bad news - no, FastScripts won't follow a symlink.

    As for clever workarounds, one idea would be to include a symlink *and* an alias in your folder. If you don't mind cluttering your folder a little bit. For instance, if you put

    ZIllustrator (SymLink ->) Your Illustrator Scripts Folder
    Illustrator (Alias ->) Your Illustrator Scripts Folder

    The ZIllustrator would get followed by rsync for your backup, and the Illustrator would get recognized by FastScripts.

    Since you'll never be running an app called "ZIllustrator", the item will never show up in your FastScripts menu.

  • Hey Daniel, thanks for the quick response! That's a good workaround. I think I'll probably just tweak my rsync script to ignore the aliases and back up the scripts in the Adobe folder separately. Unfortunately the ExtendScript environment on the Mac is so borked I can't just add ~/Library/Scripts/Applications as a "trusted source".

    Thanks again - Ian
Sign In or Register to comment.