Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Insert Bulleted List Works Only For the First Line?

edited October 2012 in MarsEdit
I've written a list then selected it and clicked "Insert Bulleted List" and find a bullet in front of only the first line, the code looks like this:

  • Notes, Notebooks, Sync, and Accounts

    Using white space, bold and italic sub-heads

    How to create numbered and unnumbered lists and tables

    How to create links and drag in images

    Sync with your smart phone or tablet

I've also tried creating a first bulleted item and then "return" before writing the second, but no go.

Maybe I'm missing something?

Thanks for any tips!

Bruce Spear


  • Sorry, the formatting was read as formatting, how's this:

  • Hi Bruce … when you say you've written a list and then selected it all, do you mean you've written just a free-form list by writing e.g. "text", return, "text", return, etc? What this is doing is creating several paragraphs. In the rich editor whenever you press return it starts a new paragraph.

    I don't think MarsEdit has a feature that would reliably convert a series of paragraphs into list items. You probably need to take care to make sure you start a new list before you start typing out the individual list items. Sorry, I can see how you would expect the behavior you're describing to work more intuitively.

    However, the part where you say you've tried "creating a first bulleted item and then "return" before writing the second" should work. What happens exactly when you try this? it should present a new bullet with blank content when you press return at the end of a list item.
  • Thanks VERY much Daniel for your thoughtful reply!

    Your explanation confirms my experience.

    a) If I first select "Insert Bulleted List" and enter items with a return, Mars Edit does indeed created a bulleted list correctly: with every return a new bulleted line is created and the cursor awaits my text. That's just fine, the app works great!

    b) If I create three paragraphs and then try to apply "Insert Bulleted List" I get only one bullet instead of three, like this:


    and then apply "Insert Bulleted List" I get


    meaning, only one bullet on the first line

    So, Mars Edit is working as you describe and my problem is that I was expecting it to behave as some of my other applications do: I have only to accept this (minor) limitation, no problem. We can close this thread.

    MANY thanks!

    Bruce Spear
  • Thanks, Bruce. I think that it would make sense and probably be more intuitive if MarsEdit also made all paragraphs into their own bullets in the transition as you described, so I am going to add a feature request to my list for that.
Sign In or Register to comment.