Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Unable to connect to IBM Connections blogs

edited March 2014 in MarsEdit
I sent an email to the support email address, so this may be a duplicate. I'm using MarsEdit V3.6.3 on Mac OSX 10.9.2 and I'm trying to connect to a blog on IBM Connections V4.5 communities. I had set configured two other blogs last fall and they worked pefectly, but for some reason, I'm getting a Null Pointer Exception. Here are the contents of the Network Log file.

Network message sent: 2014-03-21 17:00:02 +0000
Method name: metaWeblog.getRecentPosts
Network reply received: 2014-03-21 17:00:03 +0000
Method name: metaWeblog.getRecentPosts
Status code: 200
Succeeded: NO
--Fault Error--
Fault code: 0
Fault string: java.lang.Exception: java.lang.NullPointerException
Request text:
<?xml version=\"1.0\" encoding=\"utf-8\"?>

Response text:
<?xml version=\"1.0\" encoding=\"UTF-8\"?>
<methodResponse><fault><value><struct><member><name>faultString</name><value>java.lang.Exception: java.lang.NullPointerException</value></member><member><name>faultCode</name><value><int>0</int></value></member></struct></value></fault></methodResponse>

This is from a connection that used to work


  • Hi Michael - I did get your email but since you included a network log here I will reply here. Also, it may help somebody else out who has the same issue.

    I doubt that anything has changed recently in MarsEdit that would affect this. The fact that you said you had just recently updated to 4.5 of IBM Connections makes me think that's the place to look for changes first.

    The log unfortunately shows that the error is being generated on the server and passed right back to MarsEdit. It doesn't show anything obviously wrong with the way MarsEdit is sending the request. The server is simply failing (actually crashing in the Java that implements the blog server) and responding with the failure text shown in the log.

    The stuff in the log including "NullPointerException" etc is what you would want to pass along to the IBM Connections support team, probably, to ask what a blog client such as MarsEdit could do to provoke such a response.

    You might want to also try connecting to the blog from other clients such as Windows Live Writer on Windows, if you have easy access to such a client. It would be very telling if it failed in the same way on a completely different client.
  • I had one more thought, which is that if this is a completely new blog in MarsEdit, perhaps you have not had the chance to enter a password yet. If the blog server is crashing because the password is actually blank, that could explain it. You might want to try selecting the blog in MarsEdit and then selecting "Enter Password" from the gear menu near the bottom of the main window. This will let you explicitly set your password on it so it's not empty the first time MarsEdit connects to the blog.
  • Daniel, Thanks for the info. I did go into the Edit Settings and enter my password (actually tried that a couple of times). The Connections team keeps asking me what user-agent you use to connect to the connections servers. I have a meeting set up next week with one of the engineers to check the logs on their side as I try to connect through MarsEdit. BTW--this application is listed as one of the approved applications that are allowed to work with our Connections instance, so it should work (and did up until today). I know they did an update back in February, and I hadn't had a chance to post anything until now. I'll let you know what the Engineer finds.
  • Hi Mike - MarsEdit does use a custom "User Agent" but it's been the same for many, many years. It's just:

    User-Agent: MarsEdit
Sign In or Register to comment.